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INTRODUCTION
G-Electrical is a DraftSight plug-in specifically developed to create and modify electrical
designs. It requires DraftSight Professional or Enterprise 2018 SP1 or higher. It eliminates
repetitive, unproductive and manual tasks usually associated with general-purpose CAD
software. G-Electrical reduces the number of errors and enables the delivery of precise
information to manufacture, providing a higher level of productivity and quality.
Automation of
operational tasks, such
as wire numbering,
components tagging
and cross reference,
speeds up the project
development stage and
ensures
a
drastic
reduction
in
the
number of errors that
occurs
in
manual
processes. In addition,
it makes the project
development
more
dynamic.
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WHAT YOU LEARN WITH THIS CONTENT
At end of this material, you are able to:
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•
•

Use the main elements found in the interface;
Open, create and save an electrical project/drawing;
Navigate between pages;
Manage pages and page groups;
Insert table of contents, symbols table and cover;
Insert wires;
Replace wires;
Remove wires;
Edit the wire properties;
Use Components Palette;
Use G-Electrical component library;
Insert, replace and remove components;
Edit component properties;
Finding components using “Go to” tool.
Number and address wires;
Cross referencing;
Terminal numbering;
Component tagging;
Export reports (BOM, from-to and terminal strip);
Print electrical designs.
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STARTING G-ELECTRICAL
To start G-Electrical, you must have it installed on your computer as a DraftSight plugin. Please note that this plugin requires DraftSight Professional or Enterprise 2018 SP1 or
higher. If you are using any other version you may download the latest version of DraftSight
and activate the free 30 days trial of DraftSight Professional.
To start the software, double-click on the DraftSight icon found on your desktop. Or, you
can find DraftSight icon at the menu “Start > All programs > Dassault Systems > DraftSight”.
If G-Electrical is properly installed, you may be able to see at DraftSight interface a menu
called “G-Electrical”, next to menu “Tools”.

INTERFACE
Now we will learn the essential concepts about G-Electrical interface, which is divided
in: drawing area, palettes, toolbars, menus and command line.
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DRAWING AREA (1)
Drawing area is where all the work is done. The window can be resized, and the image
can be zoomed in and out.

PALETTES (2)
In G-Electrical, most of the work is done using palettes, which are the sidebars located
at both sides of the drawing area. G-Electrical has Project, Components, Wires, Connectors,
Properties, Custom and Page Palettes. Each Palette has a specific function and tools. The
Palettes allow a better management of components, wires and pages.

MENUS (3)
G-Electrical menu have been developed to help you reach any option in a faster and
simpler way. On “G-Electrical” menu, you find the electrical schematic drawing tools. In other
menus, you can find native functions from DraftSight as drawing tools.

TOOLBARS (4)
The toolbars are where the primary G-Electrical functions
are found. To enable G-Electrical toolbars, give a right-click over
other toolbar, go to “Toolbars…” and check the toolbars you
would like turn on. As you can see, there are three G-Electrical
toolbars: Electrical Standard, Electrical and Electrical Wires.

Tip: You can create your owner toolbars with rightclick over toolbars and selecting menu “Customize
Interface…”

COMMAND LINE (5)
Typing commands ease handling of software. That is not the
only thing that the Command Line can do. It also displays the options related to the command
at execution.
Try it! For example, type “L” to draw a line.
You have completed the quick overview about G-Electrical interface. Now that you know
where to find them, you can advance to the first and the very essential step, which is creating
a project.
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CREATE AN ELECTRICAL PROJECT
To create a new electrical project:

Go to: G-Electrical Menu > GE Start > New...
1) Click in “New…”
2) In the “Specify Template” dialog, select the desired template (dwt file) and click
“Open”. Thereby, a new drawing will be created.
Warning: First time that you create the project, a
configuration file (cfg extension) must be selected.
Therefore, this file remains as the default
configuration. To change it, go to “Electrical Settings…”

Tip: In a dwt file, you can store your standards, like text
styles, line styles, print configurations and more.

OPEN AN ELECTRICAL PROJECT
To open an existent electrical project:
Go to: File Menu (GE Start) > Open...
1) Click in “Open…”.
2) Select the dwg file and click at “Open” button.

CLOSE CURRENT ELECTRICAL PROJECT
To close current electrical project:
Go to: File Menu (GE Start) > Close
1) Click in “Close…”.
Warning: Do not forget to save your changes.
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WORKING WITH PAGES AND PAGE GROUPS
Pages and Page Groups are an important feature of G-Electrical. It gives you a great
freedom and convenience to organize your project, separating pages by function.
G-Electrical disposes of a Pages palette built to facilitate working with pages. Let’s look
at this important feature.
Go to: G-Electrical Menu > GE View > Pages...

INSERT PAGES
There are two ways to insert pages; the difference between them is that when you insert
a page just by right clicking on the page group, the page is inserted at the end of the list of the
pages. On the other one, you right-click one page and insert new pages next to the selected
page.
To insert pages selecting page:
1) Right-click on the current page and select the number of the pages to be
inserted, as shown in the image below. You can add one or more than one page.
Go to: Pages palette
Command: qcinsertpage
2) Edit the page properties from the dialog that appears after completing the first
step.

RESULT
The picture below shows the result obtained after inserting more than one page.
Compare it with your result.
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To insert pages selecting a page group:
1) Right-click on the page group name, select “Insert Page” and choose how many
pages you would like to insert;

2) Edit the properties of the page from the dialog that appears after completing the
first step.
Warning: This way of inserting pages is used for
inserting a page at the end of the sequence.
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REMOVE PAGES
To remove pages:
1) Select the pages to remove.
Tip: You can press the Ctrl key to select multiple pages,
or you can press the Shift key to select everything in
between the first and the last click.
2) After selecting the pages, right-click on the selected page or on any of the
selected pages. Finally, click Remove.

Warning: Deleting pages cannot be undone.

RESULT
Multiple pages have been removed.
Compare it with your result.
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EDIT PAGE PROPERTIES
To edit page properties:
Go to: G-Electrical Menu > Pages > Properties or Pages
palette right-click
Command: qceditpage
1) From the Pages palette, right click on the page and click Properties as shown
below:

2) Edit the properties as you wish and click the “Ok” button.
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QUICK REFERENCE
What is a page group?
A page group, by definition, is a folder that contains specific
content. As you know, an electrical project may consist of various
parts, each one with its specific content.
We know that the electrical schematic is made of schematic
representations of components whereas 2D Layout is composed of
their 2D representations.

How does G-Electrical manage the pages?
In Pages palette, project pages are put inside the specific folders called page groups.

You can insert, modify or remove page groups as you wish, at any time.
One or more pages can be inserted between two pages or at end of list.
As you may perceive, page groups are a good tool to organize your project.
Tip: In this lesson, you learn how to use pages and page
groups, on the next trainings you learn how set them
up.
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INSERT A NEW PAGE GROUP
To insert a new page group:
Go to: G-Electrical Menu > Pages > Right click on
“Project” > Insert Groups…
Command: qcinsgroup

1) Right-click on the root folder (project name) found on the Pages palette and
select menu “Insert Groups…”
2) Select the Page group to insert. You can select more than one at same time.

3) Edit the page group properties.
Warning: From the dialog that appears first, you can
edit the general data attributed to all pages from the
group. The next dialog is for editing the properties of
the inserted page.
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EDIT THE PAGE GROUP PROPERTIES
To edit page group properties:
Go to: G-Electrical Menu > Pages > right-click on the
group pages on the palette > Properties…
Command: qceditgroup
1) From the palette Pages, right-click on a Page group and select menu
“Properties”.
2) Edit the properties as you wish and click “Ok” button.
To copy the page or the page group properties from another:
1) From the palette Pages, give a right click on the page or page group and select

“Properties”, thereby, the properties dialog will be displayed.
2) Click “Copy from…” in Properties dialog. The Page groups dialog will appear.
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3) Select a page group and page.

INSERT COVER
To insert the cover:
Tip: The cover is a settable drawing that has properties,
texts, and lines. You can fill in with information related
to customer, manufacture or etc.
Go to: Menu G-Electrical > GE modify > Cover or rightclick on palette Pages
Command: qcinscover
1) Right-click on the root folder (project name) and select menu “Insert cover”.
2) Edit the properties page of the cover that you have been inserting.

INSERT SYMBOLS TABLE
To insert symbols table:
Go to: G-Electrical Menu > Pages > right-click on
palette Pages
Command: qcinssymbols
1) Right-click on the root folder (project name) and select menu “Insert symbols
table”.
2) Edit the properties page of the cover that you have been inserting.

INSERT TABLE OF CONTENTS
To insert table of contents:
Go to: G-Electrical Menu > Pages > right-click on
palette Pages
Command: qcinsindex
1) Right-click on the root folder (project name) and select menu “Insert table of
contents”
2) On the next dialog, you can select the pages you wish to add to the table of
contents.
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NAVIGATING BETWEEN PAGES
To navigate:
Go to: G-Electrical Menu > GE Start > Previous or Next
Command: qcprevpage or qcnextpage
Toolbar: Electrical Standard

-

Click “Previous” to go to the previous page or type the command “qcprevpage”.
Click “Next” to go to the next page or type command “qcnextpage”.
In palette Pages you can give a double-click on the page number to view the
page.
Tip: The simplest way to sequentially navigate between
pages is using the Previous Page and Next Page buttons
on the Electrical Standard Toolbar.

17

THE WIRE PALETTE
The Wire palette interface presents to user a complete range of tools to work with wires.
From now on, Wire palette will be your main interface to work with wires, where you find wire
library that you can use in the electrical design and can be organized as you wish, for example,
in next picture is by thickness. On top, you find tools to draw wire, replace wires or edit wire
properties.

Tip: Use the search button, on bottom, to find wires on
library
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WORKING WITH WIRES
In this topic, we are going to explain how to work with wires. In some cases, the same
results can be obtained following different ways.

INSERTING SINGLE PHASE WIRE
To insert a single wire:
Go to: Wires palette

1) From the Wires palette, select the wire that you want to insert. Click and hold
the left mouse button on the phase selection tool and select the first option:
“Insert single phase wire”.

2) On the drawing area, mark a point on an empty space. Drag the wire and click
on the final point to finish.
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3) Press Enter. Edit the properties and exit the command by pressing Enter.

RESULT
Single phase wire has been inserted.

Select one phase using the Phase
selection tool.

INSERTING TWO OR THREE PHASE WIRE – FIRST MODE
To insert a two or three phase wire:
Go to: Wires palette
1) Click the wire you want to insert. Click and hold your left mouse button on the
phase selection tool and select the option: “Insert three phase wire”.

20

2) Mark a point on an empty space in
the drawing area. Drag the wire
with your mouse and click on the
final point to finish drawing.
3) From the command line or by the
drawing area, inform the distance
between phases.
4) Choose a side and Edit the
properties.
5) Exit the command by Enter.

RESULT
Three phase wire has been inserted.
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INSERTING TWO OR THREE PHASE WIRE – SECOND MODE
Another way to insert one or multiphase wire:

Go to: Wires palette
1) Double click on a wire or right-click on the wire and click Insert.

2) Follow the command line. Specify the initial and the final point.

3) Write the number of ways you want to insert and press Enter.

Tip: G-Eletrical saves your last selection. To continue
with the last selection, press Enter.
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4) If you wrote two or more, you need to indicate the distance between the phases,
on Command Window.

5) The last step is choosing side. Do you want to end up placing the wire to right or
left? Edit the Properties and exit the command by Enter.

RESULT
Three-phase wire has been inserted.
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REPLACE WIRES
To replace one wire by other:

Go to: Wires palette

1) Right-click on the wire from the Wires palette.
2) Select “Replace”. You are going to see three options: “Keep
Properties”, “New Properties” and “Keep name”.
3) Click “Keep Properties”, “New Properties” or “Keep name”.
4) Click on the wire in the drawing area to replace it the wire you selected
at the Step 3.

Tip: What is the difference between the three options to
replace a wire? See on the next Quick Reference section.

RESULT
The wire has been replaced by another wire.
Old wire
New Wire

24

QUICK REFERENCE
To replace a wire, we must choose three
options, replace…
…Keep properties: This option uses the same information from
the old wire to the new wire, keeping the Wire`s Tag and information
as the diameter and color.
…New properties: This option uses the information from Data Base to the new wire, it
puts the correct diameter and color, but it loses the Wire`s Tag. You have to put the name
again.
…Keep name: This option is the most indicated, because the new wire comes with its
standard information and keeps the Wire`s Tag.
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REMOVE WIRES
To remove a wire, there are three ways:
First way:
1) Click on an item and press the Delete key from your keyboard.
Second way:
Go to: Project palette
1) From the Project Palette, select Wires from the View menu.
2) Go to Wires folder. Right click on the wire and click Remove

Third way:
1) From the drawing area, select the wire to remove.
2) Give a right-click on the wire and click Delete.

Tip: You can also use the Delete icon located on your
toolbar
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EDITING WIRE PROPERTIES
You can edit the wire properties from the properties dialog that appears at the insertion
of a wire. After insertion, to edit the wire properties, we must use the Edit Properties
To edit the wire properties after insertion:
Go to: GE Start > Properties > Select the desired wire
Command: qcddatte
Right-click menu: “Properties…”

1) Select the wire from the drawing area. Click “Edit properties…” tool.

2) Click on the column “Value” to change the property value. To show new values
in the drawing, click “Ok” button.
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Tip: Wire numbering is one of the tasks that G-Eletrical
automatically performs.
Further on this material, we will cover more details
about wires numbering.
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THE COMPONENTS PALETTE
The Components palette interface presents to user a complete range of tools to work
with components. From now on, Component palette will be your main interface to work with
components, where you find component library that you can use in the electrical design and
can be organized as you wish. On top, you find tools to insert components, replace, edit
components properties or select the standard. On bottom, you see information about item
selected on library.

1
Tools and standard combo

2
Buttons:
• search
• preview
• text details
• minimize

Tip: Use the search button, on bottom, to find wires on
library
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QUICK REFERENCE
Inserting a component on wire...
To simplify the component insertion task, when you select the
insert point over a wire, the component gets alignment from wire, so
it's a good approach start the design drawing main wires and after
insert the components. Other benefit is that inserting component on
wire, the wire is automatic broken by component size and connection
is reached.
What seems to be a simple function, saves a lot of time and clicks, if we compare to a
generic CAD tool, where you need insert the component/symbol drawing, align and break the
wire.

Tip: You can turn snaps to insert components
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WORKING WITH COMPONENTS
In this topic, we are going to explain how to work with components. In some cases, the
same results can be obtained following different ways, but to keep everything clear, we will
use just one.

INSERTING COMPONENTS
To insert a component:
Go to: Palette > Component
Command: none
1) Select a component from the Components Palette.
2) Double-click on desired component. In this case, a contactor, as the picture below.
a. Or, Drag and drop on drawing area.
b. Or, Right-click on component “Insert > Schematic”.
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3) Specify an insertion point.
Tip: The Snap options are useful for insertion.

4) Edit the properties of the component if necessary and click OK.
5) To finish the command, press Enter.

RESULT
You have successfully inserted a contactor. This contactor may have one or more contacts.
Now please advance to Inserting contacts.
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INSERTING CONTACTS
A contact may belong to a component such as a contactor, thermal relay, circuit breaker,
button, etc.
To insert a contact:

Go to: G-Electrical > Components > Insert Contacts… or
Electrical Standard Toolbar
1) Click Insert contacts from Tools menu or click Insert contacts… from Electrical
standard toolbar. After clicking, all the contacts found inside the project will
display on the Project palette.
2) On the Project palette, locate the main component and select a contact to insert.
3) To insert it, double-click on it or right-click it and click Insert.
4) Insert the contact.

RESULT
The contact was insert successfully. As you can see, the tag from contact and main component
(contactor).
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INSERTING AN EXTRA CONTACT
Extra contact are optional devices use for extend resources from main component.
To insert extra contact:
1) On Project palette, right-click on component, click Link accessories… and the
dialog “Accessories” will display.

2) Select a contact on area “Library”, double-click on contact or click on the green
plus button to add the contact.

3) Click on OK, to make available the contact connections at the main component.
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4) To use this contact on drawing, go to the Project palette.
5) Look for main component on Project palette and open Contact folder on
component.
6) Right-click on the new contact and click insert.

Tip: On contact folder, you can identify extra contacts by
the green circle.
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REPLACE A COMPONENT
You can replace a component on the drawing area by another one selecting your library
(component palette).
To replace a component:
Go to: Palette Components

1) On library (Components Palette) select the new component, right-click on it and
select one of the three options:
• To keep the value in properties, click Keep Properties.
• To fill properties with new values, click New Properties.
• To fill properties with new values and keep just the tag, click Keep Name.

2) On the drawing area, select the component to replace.
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REMOVE COMPONENT
To remove a component (using Project palette):
Go to: Project Palette
Right-click on component from the Project palette. Click Remove.

Tip: Using the Project palette, you can remove a
representation of a block found in any specific page
group.
To remove a component (using drawing area):
Go to: Edit > Erase or Modify toolbar
Command: erase
1) Click the component on the drawing area and type “Delete” or right-click, select
Delete.
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COPY A COMPONENT
To copy a component in the same page:
Go to: Modify toolbar > Copy
Command: copy

1) Click “Copy” from Modify toolbar.
2) Select a component from the drawing to copy and press Enter.
3) Specify the first and second points as illustrated above.

To copy a component to another page:
Go to: Edit > Copy or Ctrl+C
Command: clipboardcopy
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1) Click Copy tool found in the edit menu or right-click on component and click
Copy.

2) Go to other page and click Edit > Paste or Ctrl+V.

3) Select the insertion point and press enter.
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FINDING…
G-Eletrical offers a quick way to find objects inside the project and library.

…IN LIBRARY
To search in the Components library:

Go to: Palette > Components
1) On the Components palette, click search button.

2) In the text field, type some information related to the component that you want
to find.

3) Click the search button or press Enter. The results will be shown in a list.

40

To insert the component found in the search results:
1) Double-click on a component to insert it into the project.
If you click X to close the search results, G-Electrical directs you to the Components
palette, to the component’s folder.
Tip: To Find and Replace text and other advanced
features, use the Find and Replace command.

…IN PROJECT PALETTE
To search in Project Palette:
Go to: Palette > Project

1) On the Components palette, click search button.
2) In the text field, type some information related to the component that you want
to find.

3) Click the search button or press Enter, the results will be shown in a list.

4) Double-click on the component and go to schematic in drawing area. Or rightclick to see context menu options.
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…GO TO TOOL
Tip: This function is used for finding the different
representations of a component inside the project.
To search in drawing area:

Go to: G-Electrical > GE Start > Go To

1)
2)
3)
4)

Go to G-Electrical > Tools > Go to.
Select a component from the drawing area.
Choose another representation from the dialog and click Go to.
Click “Close” to finish.
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AUTOMATION OF OPERATION TASKS
Using the automation of operational tasks, such as Wire numbering, Components
tagging and Cross-referencing accelerates the project development and ensures a drastic
reduction in the number of errors that occur with manual processes. Such errors, in general,
were found only in the manufacturing stage, resulting in costly corrections and non-fulfillment
of the delivery deadlines.
G-Electrical automatically creates component tags, numbers and addresses wires. It
performs various operations related with terminals.

QUICK REFERENCE
Why do we need to number the wires?
A wire number helps to identify a wire. It helps G-Electrical to list
the wires connections established with the other wires and
components.
The process of numbering wires follows the logic below:
The wires with manual tags keep their existing tag. To the wires
that do not have numbers yet, are gave numbers. These numbers are
shown on each wire and might be shown on the drawing screen.
The distance of the number to the wire and its size can be set. The first one can be
modified in GE Manage, Wires, Number position proprieties, while the second one can be
modified directly on its block.
The wire numbers are also shown on the Project palette.
Clicking on a wire from the Project palette takes you to drawing area, to the selected
wire, as shown below.
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Both Project
palette and
drawing area
show the wire
number.

SCHEMATIC TOOLS

NUMBERING WIRES
To number the wires:
Go to: Menu G-Electrical > GE Modify > Numbering…
Command: QCWIRENUMBER

1) Insert some wires at the new drawing.
2) Go to G-Electrical > Wires > Numbering…
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3) Set the Wire tag, First number, Show numbers and Order options, click “OK” to
execute numering.

Tip: On the field “Show numbers” select “Yes” to
display wire number in the drawing.

RESULT
Wires numbered:

Horizontal order

Vertical Order
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QUICK REFERENCE
Address Wires…
G-ELETRICAL offers a considerably simple and fast way to
address wires.
If you have two wires having the same tag and disconnected
from each other, G-ELETRICAL, with the execution of this command,
draws arrows that link these matching wires between different
pages/rows/columns.

Why do we need to address the wires?
As you know, a project may consist of many pages. The circuits found in these pages
may include various connection points. In a relatively more complex projects, without
Addressing wires, it would be a little less than impossible to find out the origin and
continuation of a wire.
We hope this introduction helped you to understand the basic concept of addressing
wires.

ADDRESS WIRES
To adress the wires:
Go to: G-Electrical > GE Modify > Address
Command: qcaddresswires

1) Insert three phase wires at first page.
2) Create a new page and insert other three phase wires into the second page.
3) Tag them as shown below.

Warning: To the command wire address works, the
wire names must be the same.

4) Go to G-Electrical > Wires and click Address
46

RESULT
Address between pages:

First page

Second page

Column
Page number
Row
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QUICK REFERENCE
Cross-reference…
The cross-reference is a reference at one place in an electrical
schematic to information at another place at the same schematic.
In G-ELETRICAL, the cross-reference shows the contact position
in main component (circuit break, coil, push buttons or others) and
vice-versa.
There are two ways to display cross-reference in schematic, one is inside component
properties and other is using tables that show contact position.

CROSS-REFERENCE
To show cross-reference:
Go to: Menu G-Eletrical > GE Modify >
Cross-Reference
Command: qccompxref

1) Insert some components like contactors, buttons or circuit breakers and insert
his contacts.
2) Go to G-Electrical > Components > Cross-reference.

Tip: You can turn-on automatic cross-reference in GElectrical settings, changing Components > Crossreference > Automatic table to “Yes”
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QUICK REFERENCE
Component tag
By making use of this function, G-Electrical prevents repetitions
of component names, thus providing a greater reliability to the
electrical designs.
G-Electrical can tag components at and after their insertion. The
components have tags appropriated for their component type.
The components can be tagged sequentially or reference based.

What is prefix and suffix?
The prefix and suffix refer to the short representation of the category of a component.
Component tagging only applies to the components that have a selected prefix.
We hope this gave you an idea about Component tagging.

Tip: The prefix defines the category of a component.
For example, the prefix for a circuit breaker is DM
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COMPONENT

TAGGING

To tag the components:
Go to: Menu G-Electrical > GE Modify > Tagging…
Command: qccomptag

1) Insert some different kind (buttons, circuit breakers or fuses) of components in
the drawing.
2) Go to G-Electrical > GE Modify> Tagging.
3) Set start number at column “First number” and select which tags you would like
to number at column “Number”.
4) You can select which page(s) to tag components clicking at button “Pages…”
5) Select the order to number: vertical or horizontal.
6) Press “OK” button to execute tagging.

Tip: For multiple edit, hold the Ctrl key and select
multiple rows
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TERMINALS NUMBERING
Numbering terminals is a component tagging process applicable only for terminals.
To number terminals:
Go to: Menu G-Electrical > GE Modify > Number
Terminals
Command: qcrenumborn
sdfsdfsxdsdfssdsd
1) Insert some terminals in three different strip names (X1, X2 and X3).
2) Go to Menu G-Electrical > Components > Terminal numbering.
3) Enter the starting number for each strip (row). For example, if you enter 1, the
resulting sequence will be 1, 2, 3. And select which tags you would like to number
at column “Number”.
4) You can select which page(s) to number terminal clicking at button “Pages…”
5) Select the order to number: vertical or horizontal.
6) Press “OK” button to execute numbering.

51

RESULT
The terminals numbered:

Vertical order

Horizontal order
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PROJECT´S DOCUMENTATION
G-Electrical eliminates the risk of creating incorrect documentation and carries out this
task quickly. The consequences of incorrect documentation might be expensive, so you can
rely on the G-Electrical reports to avoid losing your time and money.
See below what kind of report G-Electrical can export:
Bill of Material
The main purpose of a bill of materials is to show the description of the components
inserted in the design and their quantities. Of course, you can show other information about
components as, part number, manufacturer, current or voltage, everything that helps you to
buy the components or to assembly the product.
From-to list
The from-to list displays the point-to-point connections between components, where
you can display component tag and pin, and information about wire like gauge, color or
manufacturer.
Terminal strip
The terminal strip shows the connections to terminals, useful to report connections
between external components and terminals inside the electrical panel.
Each one of these reports can be exported in CSV (Comma-separated values) format,
easily viewable and editable by Microsoft Excel.
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EXPORT REPORTS (BOM, FROM-TO AND TERMINAL STRIP)
To export reports:
Go to: G-Electrical > GE Start > Export
Command: qcexport
3) Go to G-Electrical > Project > Export.

4) Select what kind of data you wish to export: components, wires or terminals.
Components / Components and Wires: refers to the Bill of Materials
Terminals: refers to the Terminals List
Wires: refers to a From-to list
5) By clicking on the button “Advanced”, it is displayed the dialog “Exportation
data” to select the report properties.

54

Tip: Buttons “Up” and “Down” change properties
position

6) To add a new property, click “New” and edit it double-clicking on the property,
by the dialog “Details”.

7) On dialog “Details” fill property info:
• name – name inside the project
• description – report column label
• group – group other rows with same value
• fixed – fixed text
8) After editing properties, click on the button “OK” to go back to the dialog
“Export”.
9) On the button “Pages”, select what project pages have the information to you
would like to export.
10) On “Output file” field, inform the full file name.
11) Click on the button “Export”, at the end of the process, the file will open on
Microsoft Excel.
Tip: On Microsoft Excel, you can manipulate data with
re-order or filter.
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PRINTING
To print:
Go to: Menu G-Electrical > DraftSight Icon > Print >
Print…
Command: qcprint
1) Go to G-Electrical Menu > DraftSight icon > Print > Print…

2) Select the pages to print.
3) Set number of copies and printing order.
4) Click “Ok” to execute.
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PRINTER SETTINGS
To setup printer:
1) Click on the button “Print Configuration Manager…” from dialog “Print”.
2) Click on the button “New” and give a name for new print configuration.

3) On dialog “Print…”, set printer/plotter name and other necessary settings.
4) Click on “Save” button to go back to the dialog “Print Configuration Manager”.
5) Select new print configuration and click on “Activate”.
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6) Click on “Save” button to go back to the dialog “Print Configuration Manager”.
7) Select new print configuration and click on “Activate”.

You finished the first training…
Ok, Good! You completed the first G-Electrical training, now you are able to make your
own designs, draw the electrical schematics, work with pages, cross-reference, but there
are more, see what you can learn:
Training: Settings
- Create your own libraries (wires, components and cables)
- Customize pages
- Setup cross-reference, automatic names, wires address
We hope you enjoyed what you learned about G-Electrical and return to learn more!

Next step: Let’s go design with G-Electrical!
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